vPC Keepalive sur une VRF dédiée

Le but de cet article est de montrer comment configurer le vPC Keepalive sur une VRF dédiée sur un Nexus 7000.

 

 

 

Pré-requis

Chaque feature a besoin d'être activé sur les VDC individuellement.
En ligne de commande, se connecter sur un VDC autre que celui par défaut.
Pour le vPC, nous devons activer la feature LACP et vPC.

! Nexus 1 & 2:

feature lacp
feature vpc

 

Configuration de la VRF dédiée

Cisco recommande d'isoler le trafic keepalive dans une VRF dédiée. Si aucune VRF n'est spécifiée, alors la VRF de management sera utilisée pour le lien keepalive.

Créons d'abord la VRF dédiée puis créons le domaine vPC:

! Nexus 1 & 2 :

vrf context vpc-keepalive
vpc domain 10
peer-switch

Les 2 VDC d'un même peer devront avoir le même ID de domaine vPC.
Les IDs de domaine vPC seront différent entre les VDCs.

 

En cas d'utilisation d'OTV, l'ID de domaine vPC doit être unique sur l'ensemble des datacenters

 

La commande "role priority" permet de choisir le switch qui sera prioritaire. Plus la valeur est basse, plus la priorité sera élevée.

! Nexus 1 :

role priority 1

! Nexus 2 :

 role priority 2

 

Configuration du peer-keepalive

Nous allons indiquer l'adresse source et l'adresse destination du keepalive.
Ces adresses font parties de la VRF créée précédemment.

! Nexus 1 :

peer-keepalive destination 1.1.1.2 source 1.1.1.1 vrf vpc-keepalive

! Nexus 2 :

 peer-keepalive destination 1.1.1.1 source 1.1.1.2 vrf vpc-keepalive

 

Configuration des interfaces

! Nexus 1 :

interface Ethernet5/1
description -VPC Peer Link-
switchport
channel-group 10 mode active

interface Ethernet6/1
description -VPC Peer Link-
switchport
channel-group 10 mode active

interface port-channel10
description -VPC Peer Link-
switchport
 vpc peer-link

! Nexus 2 :

 interface Ethernet5/1
description -VPC Peer Link-
switchport
channel-group 10 mode active

interface Ethernet6/1
description -VPC Peer Link-
switchport
channel-group 10 mode active

interface port-channel10
description -VPC Peer Link-
switchport
 vpc peer-link

 

La commande "vpc peer-link" configure le port-channel en tant que peer-link vPC.
Le lien peer-link est un trunk. Tous les Vlans des vPC pourront traverser ce lien.

! Nexus 1 :

interface port-channel11
description -VPC Keepalive-
vrf member vpc-keepalive
 ip address 1.1.1.1/30

interface Ethernet5/2
description -VPC Keepalive-
channel-group 11 mode active

interface Ethernet6/2
description -VPC Keepalive-
channel-group 11 mode active

! Nexus 2 :

 interface port-channel11
description -VPC Keepalive-
vrf member vpc-keepalive
ip address 1.1.1.2/30

interface Ethernet5/2
description -VPC Keepalive-
channel-group 11 mode active

interface Ethernet6/2
description -VPC Keepalive-
channel-group 11 mode active

La manipulation est à répéter pour chaque VDC.

Informations supplémentaires